Back to overview
Downtime

Service Outage

May 19, 2026 at 10:30pm UTC
Affected services
Web App
API
Database
Subscription Sync

Resolved
May 20, 2026 at 2:55am UTC

All LawCite services are fully restored. Railway has closed their incident and published a postmortem.

The outage was caused by Google Cloud incorrectly suspending Railway's production account via an automated action — an error that affected many GCP customers simultaneously. The suspension took Railway's control plane offline, which cascaded to all workloads across their entire network, including regions not hosted on Google Cloud.

Total impact window for LawCite: approximately 22:20 UTC May 19 to ~02:55 UTC May 20 (~4.5 hours of full unavailability).

Railway has outlined architectural changes underway to prevent a single provider action from cascading platform-wide in the future. We will continue to evaluate our infrastructure dependencies as Railway makes those improvements.

Updated
May 20, 2026 at 1:41am UTC

LawCite services are back online as of earlier today. Railway has recovered compute on Google Cloud, though their underlying networking incident with Google Cloud remains open and unresolved.
We are keeping this status active and monitoring closely until Railway closes their incident. There is a possibility of further disruption while the root cause is fully remediated. We will update this page if service is impacted again or when Railway confirms full resolution.

Created
May 19, 2026 at 10:30pm UTC

All LawCite services are currently offline. This is caused by a major infrastructure outage at Railway, our hosting provider, which is in turn caused by Google Cloud blocking Railway's account access. Railway is in direct contact with Google Cloud's support team and has confirmed the cause — restoration is underway, but no ETA has been provided.

This is entirely outside our control and we are monitoring Railway's status page closely. We will update this status as soon as Railway confirms services are restored.

Last updated: May 19, 2026 — tracking Railway incident report.